CCNA LAB

How to Configure EIGRP Routing on Cisco Router? Simple Explanation of Eigrp Protocol?

In this article, I’ll explain the simple configuration of EIGRP protocol on Cisco routers. But before to this, we must have an idea about EIGRP protocol that What is EIGRP Protocol? How to use it? Where can we use this protocol? Friends if you want to earn all the information about EIGRP then please read the complete article. EIGRP stands for Enhanced Interior Gateway Routing Protocol. It is an advanced distanced – vector protocol that is used for automatic configuration and decision making for a network. It is a sole Proprietary protocol available on Cisco Router especially designed by Cisco Systems for the purpose of Proprietary on Routing protocol of Cisco routers.

 Basic features of EIGRP protocol –

  • It uses the SPF algorithm which means Shortest Path First, so it connects first to the nearest device.
  • Establish a connection with the neighbour.
  • It is an RTP that is Reliable Transport Protocol.
  • It updates the routing table periodically.
  • It sends each update to all EIGRP routers.

The Best Usage of EIGRP protocol?

The best use of EIGRP routing protocol is at the private networks because it provides the best services like scalability, speed, ease of management.

Let’s learn the configuration of EIGRP on the Cisco router. Please watch given lab very carefully.

EIGRP Routing Protocol on Cisco Routers.

                                                EIGRP Routing Protocol on Cisco Routers.

Now follow my steps to configure EIGRP on Cisco Routers.

1. Assign an IP address to all Router interfaces and all Systems/PCs.

On Router0

R0(config)#interface FastEthernet0/0

Router(config-if)#ip address 1.0.0.1 255.0.0.0

Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface FastEthernet0/1

Router(config-if)#ip address 2.0.0.1 255.0.0.0

Router(config-if)#no shutdown

On Router 1

R1(config)#interface FastEthernet0/0

Router(config-if)#ip address 2.0.0.2 255.0.0.0

Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface FastEthernet0/1

Router(config-if)#ip address 3.0.0.1 255.0.0.0

Router(config-if)#no shutdown

On Router2

Give IP address to Interface Fa0/0 that is FastEthernet0/0

R2(config)#interface FastEthernet0/0

Router(config-if)#ip address 4.0.0.1 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#exit

Give IP address to Interface Fa0/1 that is FastEthernet0/1

Router(config)#interface FastEthernet0/1

Router(config-if)#ip address 3.0.0.2 255.0.0.0

Router(config-if)#no shutdown

On PC1

IP Config on PC

                                                                                                                IP Config on PC

On PC2

IP Config on PC

                                                                                                           IP Config on PC

 

2. Now Configure EIGRP Protocol in Configure Terminal Mode

On Router0 

Give the network address known to the Router Interfaces. 

Router(config)#router eigrp 1
Router(config-router)#net 1.0.0.0
Router(config-router)#net 2.0.0.0

On Router1

Give the network address known to the Router Interfaces. 

Router(config)#router eigrp 1
Router(config-router)#net 3.0.0.0
Router(config-router)#net 2.0.0.0

On Router2 

Give the network address known to the Router Interfaces.  

Router(config)#router eigrp 1
Router(config-router)#net 3.0.0.0
Router(config-router)#net 4.0.0.0

Also Read :

1. Compression And decompression of files the Linux System in very simple methods.
2. Installation of YUM Server through ISO File System in Linux.
3. Backup of Cisco Router Data with FTP Server.
4. How to Telnet on Cisco Routers?

3. Now Check the Routing Table of Routers

On Router0 

Put this show ip command in Enable Mode to check the Eigrp Protocol Configuration. 

Router#show ip route
Gateway of last resort is not set

C    1.0.0.0/8 is directly connected, FastEthernet0/0

C    2.0.0.0/8 is directly connected, FastEthernet0/1

D    3.0.0.0/8 [90/30720] via 2.0.0.2, FastEthernet0/1

D    4.0.0.0/8 [90/33280] via 2.0.0.2, FastEthernet0/1

On Router1 

Put this show ip command in Enable Mode to check the Eigrp Protocol Configuration. 

Router#show ip route

Gateway of last resort is not set

D 1.0.0.0/8 [90/30720] via 2.0.0.1, 00:06:07, FastEthernet0/0

C 2.0.0.0/8 is directly connected, FastEthernet0/0

C 3.0.0.0/8 is directly connected, FastEthernet0/1

D 4.0.0.0/8 FastEthernet0/1

On Router2 

Put this show ip command in Enable Mode to check the Eigrp Protocol Configuration. 

Router#show ip route
Gateway of last resort is not set

D 1.0.0.0/8  via 3.0.0.1, FastEthernet0/1

D 2.0.0.0/8  via 3.0.0.1,, FastEthernet0/1

C 3.0.0.0/8 is directly connected, FastEthernet0/1

C 4.0.0.0/8 is directly connected, FastEthernet0/0

 

In this post, we have learned that What is EIGRP Routing Protocol? What are the components of EIGRP? Where to use it? and How to configure Eigrp routing protocol in a very way. Guys hopes, you like my posts but if you have doubts or any queries with this post then don’t hesitate to contact me. And if you have any suggestions for me then please write to me in the comment box. If you like my posts please share it with your friends

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s