CCNA LAB

How to Configure Static Routing on Cisco Router?

In this article, we will learn “How to configure Static on Cisco Router”.  Here we can learn static routing protocol on router. So, first of all, we should know that  What is Static Routing or Protocol? Dear one if you know the answer please mention it in the comment box and if don’t know then continue your reading. So basically it is manually configured routing protocol to send traffic at particular destinations on a router rather than dynamic routing protocol. So through a static protocol, a dynamic path can’t be provided automatically to connect 2 routers. So in the static protocol, we manually configure network address to the router.  Let’s Learn how to configure Static Routing Protocol on Cisco Router?

We have a Cisco Packet Tracer Lab below. Here I have taken 3 routers and perform static routing over them. Watch it carefully and then perform it.


Static Routing

1. Assign IP to all Interfaces and Systems.

On Router 1 

Router(config)#hostname R1

Rq(config)#interface FastEthernet0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shut

R1(config)#interface FastEthernet0/1

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#no shut

On Router 2

Router(config)#hostname R2

R2(config)#interface FastEthernet0/0

R2(config-if)#ip address 2.0.0.2 255.0.0.0

R2(config-if)#no shut

R2(config)#interface FastEthernet0/1

R2(config-if)#ip address 3.0.0.1 255.0.0.0

R2(config-if)#no shut

On Router 3

Router(config)#hostname R3

R3(config)#interface FastEthernet0/0

R3(config-if)#ip address 3.0.0.2 255.0.0.0

R3(config-if)#no shut

R3(config)#interface FastEthernet0/1

R3(config-if)#ip address 4.0.0.1 255.0.0.0

R3(config-if)#no shut

2. Do Static IP on All Routers

Router(config) net subnet mask IP address through which you want to connect with other address.

On Router 0

R1(config)#ip route 3.0.0.0 255.0.0.0 2.0.0.2

R1(config)#ip route 4.0.0.0 255.0.0.0 2.0.0.2

On Router 1

R2(config)#ip route 1.0.0.0 255.0.0.0 2.0.0.1

R2(config)#ip route 4.0.0.0 255.0.0.0 3.0.0.2

On Router 2

R3(config)#ip route 2.0.0.0 255.0.0.0 3.0.0.1

R3(config)#ip route 1.0.0.0 255.0.0.0 3.0.0.1

Note – 1. ‘IP route’ is the command of Static Routing protocol.

2. Put the IP address of networks you want to connect with.

3. Type subnet mask of Ip address.

4. Interface Ip address through which router will communicate with other routers.

3. Check Whether Static Routing Configured or Not

Router#show ip route

Codes: C -stands for connected, S  stands for static.

C 1.0.0.0/8 is directly connected, FastEthernet0/0
C 2.0.0.0/8 is directly connected, FastEthernet0/1
S 3.0.0.0/8 [1/0] via 2.0.0.2
S 4.0.0.0/8 [1/0] via 2.0.0.2

Pros and Cons of Static Protocol.

  1. Static routing is easy to troubleshoot.
  2. It is easy for small organisation/networks while not suitable for a large organisation.
  3. It is very hard to implement in large networks.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s