CCNA LAB

Learn How To Configure Telnet Server in Cisco Router

In this tutorial, you will learn about configuring the Telnet server in the Cisco router. We configure Telnet services on a router to access it from anywhere remotely. If you are at a remote location and you want to configure, manage, and monitor your router from a remote location. Then you can control your router remotely through telnet without your physical presence actually where your router is. So, basically, Telnet is a remote login program that helps us to manage any device remotely. We will learn configuring telnet through the given diagram watch it very carefully and read it step by step.

 

Telnet Configuration on Cisco router

telnet on cisco router

In this lab, I configured Telnet on Router0. And Router1 is used to connect the network. So to Configure telnet on cisco router, first of all, you have to assign the IP address to PCs and Routers as and where necessary. In the above diagram, you can watch it.

Command for Router0

Router>enable

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.  

Router(config)#interface FastEthernet0/0

Router(config-if)#ip address 1.0.0.1 255.0.0.0

Router(config-if)#exit
Router(config)#interface FastEthernet0/1

Router(config-if)#ip address 3.0.0.1 255.0.0.0

Router(config-if)#exit
Router(config)#username user1 password user1

Router(config)#username user2 password user2

Router(config)#username user3 password user3
Router(config)#router rip

Router(config-router)#version 2

Router(config-Router)#network 1.0.0.0

Router(config-Router)# network 3.0.0.0
Router(config)#enable password deepak

Router(config)#line vty 0 4

Router(config-line)#password ccna

Router(config-line)#login local

Router(config-line)#exit
(Note – 1. Before configuring Telnet on Router It is compulsory to set the password to your router for security purposes. You can see the highlighted command by which normal level security can be done on router. 2. Also, give static IP to PCs as shown in the figure. )

 

Command for Router1

Router>enable

Router#conf t

Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface FastEthernet0/0

Router(config)#ip address 2.0.0.1 255.0.0.0

Router(config)#exit
Router(config)#interface FastEthernet0/1

Router(config)#ip address 3.0.0.2 255.0.0.0

Router(config)#exit
Router(config)#router rip

Router(config-router)#version 2

Router(config-Router)#network 2.0.0.0

Router(config-Router)# network 3.0.0.0

(Note – Rip Protocol is used for routing between both router. You can do your choice.)

Now it’s time to whether your Telnet server is configured on Router or not. So let’s check

  • Click on any PC connected to switch
  • Click on Command Prompt  show in the Dialog box
  • Type below command shown in Picture
  • If it is correct then You have successfully configured telnet on the router.

Telnet server

In this post, we have learned how to configure telnet on cisco router. Guys if you have doubts or any queries with this post then don’t hesitate to contact me. And if you have any suggestions for me then please write to me in the comment box. If you like my posts please share it with your friends.

 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s